Cours : Le relais de trames (Frame Relay) en détails

Bonjour et bienvenue sur coursnet, aujourd’hui on va vous présenter un cours qui parle du frame relay en détails ...
Catégorie de cours : Réseau informatique , ccna
Sujet de cours :  FRAME RELAY en détails


Cours : Le relais de trames (Frame Relay) en détails

FRAME RELAY (RELAIS DE TRAMES)

Frame Relay est un protocole de réseau étendu qui agit au niveau des couches physique et liaison de données du modèle OSI. Ce protocole est utilisé par les fournisseurs d’accès pour transmettre des signaux-vocaux et numériques entre réseaux locaux par l’intermédiaire d’un réseau étendu.
Frame Relay est un protocole de réseau étendu très répandu car il est de faible coût par rapport aux lignes dédiées et d’une grande flexibilité.

A la fin des années 70, des sites distants étaient généralement reliés en utilisant le protocole X.25. Ce protocole permettait d’obtenir une connexion réseau très fiable sur des infrastructures câblées non fiables grâce à un contrôle de flux et d’erreurs.
Frame Relay, le remplaçant de X.25, demande moins de temps de traitement que X.25 car il ne fournit pas de corrections d’erreurs. 

La propagation des données informatiques est donc très rapide.Lorsque Frame Relay est utilisé pour connecter des réseaux locaux, le DTE sur chacun des réseaux est un routeur, le commutateur Frame Relay est un DCE

CIRCUITS VIRTUELS


Cours : Le relais de trames (Frame Relay) en détails

En Informatique, un circuit virtuel désigne une connexion logique entre deux DTE par un réseau Frame Relay. On distingue deux types de circuits virtuels :
  • Le circuit virtuel commué (SCV)
  • Le circuit virtuel permanent (PVC)
Un circuit virtuel peut passer par un nombre quelconque de commutateurs du réseau Frame Relay.Un circuit virtuel est identifié par un indicateur de connexion de liaison de données appelé DLCI. Il est généralement attribué par le fournisseur de service Frame Relay et a uniquement une signification locale.
Le DLCI est stocké dans le champ d’adresse de chaque trame indiquant ainsi où la trame doit être acheminée. La valeur d’un DLCI varie entre 16 et 1007.
Le réseau Frame Relay est statistiquement multiplexé. Cela signifie qu’il ne transmet qu’une trame à la fois, mais que plusieurs connexions logiques peuvent coexister sur la même ligne physique. Ainsi, chaque point d’extrémité ne nécessite qu’une ligne d’accès et une interface.

FRAME RELAY ET L'ENCAPSULATION 

Frame Relay reçoit un paquet de la couche réseau. Il lui adjoint un champ d’adresse et une somme de contrôle. Finalement, des champs d’indicateur de début et de fin de trame sont ajoutés. La trame est alors passée à la couche physique.
Le champ d’adresse contient le DLCI (les FECN, BECN et DE). La somme de contrôle est calculée puis insérée dans la trame par la source. Le destinataire recalcule le FCS. Si les résultats sont identiques, il traite la trame réseau, sinon il l’abandonne.

TOPOLOGIES FRAME RELAY

On distingue trois types de topologie réseau :
  • En étoile
  • A maillage global
  • A maillage partiel

FRAME RELAY ET LA MAPPAGE DES ADRESSES

Afin d’envoyer des données informatiques à l’aide du protocole Frame-Relay, le routeur doit connaitre la relation entre le DLCI local et l’adresse de couche 3 de la destination.
Il existe deux types de mappage :

  • Mappage dynamique
  • Mappage statique
Le mappage dynamique utilise l’inverse ARP pour résoudre l’adresse IP du saut suivant en une valeur DLCI locale. Il stocke ces informations dans sa table de mappage.
Pour voir le contenu de cette table : show frame-relay map.
Sur les routeurs Cisco l’ARP inverse est activé par défaut. Le mappage statique est utilisé lorsqu’un routeur ne prend pas en charge l’inverse ARP ou qu’un réseau Frame-Relay est constitué d’une topologie en étoile.

INTERFACE DE SUPERVISION LOCALE (LMI)

LMI (Local Management Interface) est un mécanisme de test d’activité qui fournit des informations sur les connexions Frame Relay entre le routeur DTE et le switch Frame Relay (DCE). Si le réseau ne fournit pas les informations demandées, le routeur peut considérer la connexion comme coupée.
Le commutateur et le routeur doivent utiliser le même LMI. Il existe différents types d’interfaces LMI, incompatibles entre elles :

  • Cisco     
  • Ansi      
  • q933a 
Cours : Le relais de trames (Frame Relay) en détails
Depuis l’IOS Cisco 11.2, le routeur détecte automatiquement la LMI utilisée par le commutateur et configure son interface en fonction.On configure le LMI avec la commande :
frame-relay lmi-type [cisco | ansi |q933]

UTILISATION DU LMI DE l’ARP INVERSE POUR LE MAPPAGE DES ADRESSES

Le routeur (DTE) se connecte au réseau Frame-Relay et envoie une LMI. Le réseau répond par un message d’état LMI donnant des informations sur les circuits virtuels configurés sur la liaison.
Le routeur doit alors mapper ces circuits virtuels à des adresses de couche 3. Pour ce faire, il envoie un message ARP inverse sur chaque circuit virtuel. Il peut alors effectuer le mappage. Il profite aussi lors de l’envoi de son message pour envoyer son adresse réseau afin que le routeur distant puisse aussi effectuer son propre mappage. 

CONFIGURATION DE BASE  FRAME RELAY (MAPPAGE DYNAMIQUE)

Pour configurer une interface série avec le protocole Frame Relay :
R1(config)#interface serial 0/0
R1(config-if)#ip address ad IP masque reseau

On configure l’encapsulation :
R1(config-if)#encapsulation frame-relay [ietf | cisco]
Rappelons que le type d’encapsulation Frame Relay par défaut est cisco. Le type d’encapsulation ietf s’utilise lorsque le routeur distant n’est pas cisco. Les routeurs d’extrémité doivent utiliser la même encapsulation frame relay. Finalement la configuration du lmi est automatique, donc facultative.
Pour vérifier la configuration : 

R1(config)# show interfaces serial 0/0

CONFIGURATION D'UN MAPPAGE STATIQUE FRAME RELAY

Dans ce cas on établit manuellement le mappage entre l’adresse réseau du routeur distant et le numéro DLCI local.
Désactiver l’inverse-map :
R1(config-if)# no frame-relay inverse-arp
R1(config-if)# frame-relay map ad IP numero DLCI [broadcast|cisco|ietf ]
Remarques :

  • Il faut utiliser ietf si le routeur auquel on se connecte n’est pas de type cisco.
  • Le réseau Frame Relay est un réseau informatique NBMA (non-broadcast multiaccess). Cela signifie qu’il ne prend pas en charge par défaut la diffusion et la multidiffusion. Lors de l’utilisation de protocoles de routage, le mot-clé broadcast permet cette diffusion ou multidiffusion sur le circuit virtuel permanent.
DÉCOUPAGE D'HORIZON
Un réseau FrameRelay est de type NBMA et possède généralement une topologie en étoile. Un protocole de routage à vecteur de distance utilise la technique du découpage d’horizon pour éviter les boucles de routage.
Rappel : 

le découpage d’horizon empêche qu’une mise à jour de routage reçue sur une interface physique ne soit retransmise par la même interface. Dans le cas d’un réseau étoile cela signifie que les mises à jour ne peuvent pas être acheminées sur tout le réseau informatique .
Plusieurs solutions se présentent :

  • Désactivation du découpage d’horizon    
  • Topologie à maillage global    
  • Utilisation de sous-interfaces

FRAME RELAY ET LES SOUS-INTERFACES

Frame Relay peut partitionner une interface physique en plusieurs interfaces virtuelles ou sous-interfaces, à chacune est associée un circuit virtuel permanent. Une sous interface peut être configurée en mode point à point ou multipoint.

Point à point : 

Une sous-interface point à point établit une connexion par circuit virtuel permanent à une interface physique ou une sous-interface d’un routeur distant.
Chaque paire de routeurs point à point réside sur son propre réseau informatique et chaque sous-interface point à point ne dispose que d’un DLCI. Dans ce cas, le découpage d’horizon n’intervient pas.


Multipoint : 

Une seule sous-interface établit plusieurs connexions de circuit virtuel permanent à plusieurs interfaces physiques ou sous-interfaces sur des routeurs distants. Tous les circuits virtuels multipoint appartiennent au même sous réseau. Dans ce cas, le découpage d’horizon intervient.
La commande encapsulation frame-relay s’applique à l’interface physique, les autres éléments de configuration s’appliquent (ad IP, DLCI) aux sous-interfaces.

CONFIGURATION DE SOUS-INTERFACES FRAME RELAY POINT A POINT  point

Prenons l’exemple ci–dessous et configurons l’interface série S0 du routeur R1.
Sur l’interface physique, 

On indique le type d’encapsulation :
R1(config-if)# encapsulation frame-relay
On configure alors les sous-interfaces logiques en indiquant le numéro de DLCI pour des raisons d’organisation. 

Première sous interface logique :
R1(config-if)# int S0.102 point-to-point
On indique alors son adresse IP ainsi que son DLCI :
R1(config-if)# ip address 10.1.1.2 255.255.255.252
R1(config-if)# frame-relay interface-dlci 102
Seconde sous interface logique :
R1(config-if)# int S0.103 point-to-point
On indique alors son adresse IP ainsi que son DLCI :
R1(config-if)# ip address 10.1.1.5 255.255.255.252
R1(config-if)# frame-relay interface-dlci 103
Finalement, on effectue l’activation des sous-interfaces depuis l’interface physique
avec la commande no shutdown.

CONFIGURATION DU SWITCH FRAME-RELAY

On commence par activer la commande Frame-Relay sur le routeur lui permettant de transférer des trames sur la base des DLCI entrant : 
SFR(config)#frame-relay switching

Sur l’interface choisie on modifie le type d’encapsulation :
SFR(config)#interface S0/0
SFR(config-if)#encapsulation frame-relay
On indique alors que l’interface est de type DCE :
SFR(config-if)#frame-relay intf-type dce
SFR(config-if)#clock-rate vitesse
On configure alors le Switch Frame-Relay pour qu’il transfère le trafic entrant ici sur l’interface S0/0 ayant le DLCI x vers par exemple l’interface S0/1 ayant le DLCI y. 

On crée ainsi le premier PVC :
SFR(config-if)#frame-relay route x interface serial 0/1 y
SFR(config-if)#no shutdown
On crée alors le second PVC pour le retour :
SFR(config)#interface S0/1
SFR(config-if)#encapsulation frame-relay
SFR(config-if)#frame-relay intf-type dce
SFR(config-if)#clock-rate vitesse
SFR(config-if)#frame-relay routey interface serial 0/0 x
SFR(config-if)#no shutdown
On vérifie la configuration avec la commande : show frame-relay pvc.

Paiement de Frame Relay

Un client achète un service Frame Relay à un fournisseur de services. Pour comprendre le paiement d’un tel service, il est nécessaire de connaitre les notions suivantes :
  • Débit d’accès ou vitesse du port : débit auquel le circuit accède au réseau Frame Relay. La vitesse du port est cadencée par le switch Frame Relay.
  • Débit de données garanti (CIR) : correspond à la quantité de donnés informatiques que le réseau Frame Relay reçoit du circuit d’accès. Ce débit est garanti par le fournisseur de services.
Frame Relay met à la disposition des clients tout capacité inutilisée du réseau appelée rafales  supérieures à leur CIR, en général gratuitement.
Un client paie donc pour une connexion Frame Relay :

  • Frais d'équipement d’abonné                    
  • Débit d’accès                    
  • Circuit virtuel permanent                    
  • CIR
Les fournisseurs font parfois de la surréservation en vendant plus de bande passante que disponible, en supposant que tous les clients n’utilisent pas en permanence toute la bande passante qu’ils ont louées. Il peut en résulter des problèmes de trafic réseau.

Rafales ( Informatique )

Les circuits physique du réseau Frame Relay sont partagés entre les abonnés. Il arrive qu’un surplus de bande passante soit disponible. Un client peut envoyer alors gratuitement en rafales des données informatiques excédant son CIR. la durée des rafales doit être de quelques secondes.
Les termes suivants permettent de d’écrire les débits de rafale :

  • Dèbit garanti en rafale ou CIBR         
  • Débit garanti en excès ou BE
Le CIBR est un débit négocié par le client en plus du CIR. La durée d’une rafale doit être courte, sinon le client doit acheter plus de CIR.
Le BE correspond à la bande passante disponible au dessus du CBIR jusqu’au débit d’accès de la liaison. Ce surplus de débit n’est pas négocié. Les trames transmises à ce débit sont très sujettes a l’abandon.

CONTROLE DE FLUX FRAME RELAY

Frame Relay utilise des mécanismes d’encombrement simples comme :
  • Notification explicite d’encombrement au destinataire ou FECN.
  • Notification explicite d’encombrement à la source ou BECN.
Les notifications explicites d’encombrement sont indiquées par un bit dans l’entête de la trame. le routeur détecte l’encombrement et arrête la transmission jusqu’à ce que la situation normale soit rétablie.
Les trames réseau qui arrivent au switch Frame Relay sont mises en file d’attente. Lors d’une accumulation excessive de trames, le switch signale le problème aux routeurs à l’aide des bits de notification explicite d’encombrement :

  • Les équipements en aval sont informés de la file d’attente en configurant le bit FECN.
  • Les équipements en amont sont informés de la file d’attente en configurant le bit BECN.
L’entête de trame contient également un bit d'éligibilité à la suppression (DE). Les trames dont le bit est à 1 sont considérées comme moins importantes et peuvent être abandonnées pendant une période d’encombrement.
Les règles logiques sont appliquées :

  • Si la trame entrante ne dépasse pas le CIBR, la trame passe.
  • Si la trame entrante dépasse le CIBR, son bit DE est fixé à 1.
  • Si la trame entrante dépasse le CIBR augmenté du BE, elle est abandonnée.

Fin de cours

Les meilleurs cours d'informatique vous les trouvez sur coursnet.com


Fourni par Blogger.